VMime Mail Library
-
Updated
Oct 3, 2026 - C++
VMime Mail Library
Fast, lightweight Node.js email validation library — RFC 5322, typo detection, disposable email blocking, MX & SMTP verification. TypeScript-first. 25KB.
A simple (but correct) library for validating email addresses. Supports mail addresses as defined in rfc5322 as well as the new Internationalized Mail Address standards (rfc653x). Based on https://github.com/jstedfast/EmailValidation
The Email Address Validation Library
Very small e-mail validation helper written in Swift
Email for AI agents. Rust CLI on Resend with a local SQLite mailbox. Works in Claude Code, Cursor, Codex, Warp, Gemini CLI.
Simple Pest based parser for E-Mail headers like From, To, Cc, Bcc, etc. (Mirror - report issues to Repo hosted on Codeberg)
RFC 5321/5322/6531 email address parser, validator, and normalizer for Rust. Subaddress extraction, provider-aware normalization, PSL domain validation, anti-homoglyph protection.
Production-grade Gmail SMTP configuration, Microsoft 365 Group delivery runbook, RFC 2047 Thai header encoder, and anti-spam deliverability optimization toolkit.
Syntax highlighting for RFC 5322 email addresses
VMime Mail Library
A wicked fast UTF-8 email address parser and serializer conforming to RFC 5322 and RFC 6532
RFC 5321, 5322, and 6531 email address validation and parsing for Swift.
Email id parser for email address as defined in RFC5322 'addr-spec' using Finite Automaton implemented in Rust.
To associate your repository with the rfc-5322 topic, visit your repo's landing page and select "manage topics."