Repository navigation
doc: update supported linux/glibc baseline - #1324
Conversation
|
LGTM. Do we plan to remove any workarounds we have in place for older glibc versions? (IIRC there is some dlsym-ing around for some functions). |
|
I believe we only dlsym for android, which I didn't plan on touching. We could remove quite a bit of < 2.6.32 support code (code paths that work around missing system calls) but I'm undecided if we should do that at this time. |
Maybe for v2? |
|
Surely for V2 then! :-) |
|
Yes, it certainly make sense for v2. For v1.x, I'd say we keep it until it becomes a pain to maintain (which is subjective but that is what consensus is for.) I'll go ahead and merge this. |
Now that RHEL/CentOS 5 is end-of-life, update the baseline from linux >= 2.6.18 + glibc >= 2.5 to linux >= 2.6.32 + glibc >= 2.12. PR-URL: libuv#1324 Refs: nodejs/node#12672 Reviewed-By: Colin Ihrig <cjihrig@gmail.com> Reviewed-By: Saúl Ibarra Corretgé <saghul@gmail.com>
9d4292b to
4e61013
Compare
|
Agreed! |
Now that RHEL/CentOS 5 is end-of-life, update the baseline from
linux >= 2.6.18 + glibc >= 2.5 to linux >= 2.6.32 + glibc >= 2.12.
Refs: nodejs/node#12672