Skip to content
Merged
Show file tree
Hide file tree
Changes from all commits
Commits
Show all changes
48 commits
Select commit Hold shift + click to select a range
2855c75
[1password] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
3ec3b1e
[akamai] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
b8957ff
[amazon_security_lake] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
b1417b2
[arista_ngfw] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
63ca8d7
[atlassian_bitbucket] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
b7f8972
[atlassian_confluence] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
c435694
[atlassian_jira] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
10aa6f8
[auditd] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
6350f7b
[auditd_manager] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
c489086
[auth0] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
7f93c8d
[azure_blob_storage] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
3a390de
[azure_frontdoor] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
f1eba34
[barracuda] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
146ff0f
[barracuda_cloudgen_firewall] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
1a7c05b
[bitdefender] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
8e1119b
[bitwarden] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
bad6432
[box_events] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
47a0c56
[carbon_black_cloud] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
fbc75c9
[carbonblack_edr] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
b6487d4
[cef] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
1086f16
[cel] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
f40c0d3
[checkpoint] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
3e6d8dc
[cisco_aironet] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
5232644
[cisco_asa] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
30aea98
[cisco_duo] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
02390aa
[cisco_ftd] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
a6f0abd
[cisco_ios] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
fa43a62
[cisco_ise] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
73d62bd
[cisco_meraki] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
e13a5be
[cisco_nexus] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
886515a
[cisco_secure_email_gateway] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
83e9518
[cisco_secure_endpoint] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
34d3323
[cisco_umbrella] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
83776e7
[citrix_waf] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
2ba4f5f
[cloudflare] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
118649a
[cloudflare_logpush] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
cd11867
[crowdstrike] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
488c03b
[cyberark_pta] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
1d5f831
[cyberarkpas] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
3e3ca9a
[cylance] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
ff51b4f
[darktrace] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
9218574
[entityanalytics_entra_id] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
3b3a113
[entityanalytics_okta] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
dc36583
[f5_bigip] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
649c5d1
[fim] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
fbf485a
[fireeye] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
e8be893
[forcepoint_web] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
3d8124a
[forgerock] - change to ECS version git@v8.11.0
chemamartinez Nov 8, 2023
File filter

Filter by extension

Filter by extension

Conversations
Failed to load comments.
Loading
Jump to
The table of contents is too big for display.
Diff view
Diff view
  •  
  •  
  •  
2 changes: 1 addition & 1 deletion packages/1password/_dev/build/build.yml
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
dependencies:
ecs:
reference: "git@v8.10.0"
reference: "git@v8.11.0"
5 changes: 5 additions & 0 deletions packages/1password/changelog.yml
Original file line number Diff line number Diff line change
@@ -1,4 +1,9 @@
# newer versions go on top
- version: 1.25.0
changes:
- description: ECS version updated to 8.11.0.
type: enhancement
link: https://github.com/elastic/integrations/pull/8433
- version: "1.24.0"
changes:
- description: Improve 'event.original' check to avoid errors if set.
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@
{
"@timestamp": "2022-10-24T21:16:52.827Z",
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"action": "suspend",
Expand Down Expand Up @@ -72,7 +72,7 @@
{
"@timestamp": "2022-10-24T21:16:52.827Z",
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"action": "suspend",
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -17,7 +17,7 @@ processors:
#######################
- set:
field: ecs.version
value: "8.10.0"
value: "8.11.0"
# Sets event.created from the @timestamp field generated by filebeat before being overwritten further down
- set:
field: event.created
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@
"type": "logs"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"elastic_agent": {
"id": "f25d13cd-18cc-4e73-822c-c4f849322623",
Expand Down Expand Up @@ -84,4 +84,4 @@
"user": {
"id": "GLF6WUEKS5CSNDJ2OG6TCZD3M4"
}
}
}
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@
{
"@timestamp": "2021-08-30T18:57:42.484Z",
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"action": "reveal",
Expand Down Expand Up @@ -78,7 +78,7 @@
{
"@timestamp": "2021-08-30T19:10:00.123Z",
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"category": [
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -17,7 +17,7 @@ processors:
#######################
- set:
field: ecs.version
value: '8.10.0'
value: '8.11.0'
# Sets event.created from the @timestamp field generated by filebeat before being overwritten further down
- set:
field: event.created
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@
"type": "logs"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"elastic_agent": {
"id": "f25d13cd-18cc-4e73-822c-c4f849322623",
Expand Down Expand Up @@ -77,4 +77,4 @@
"full_name": "Name",
"id": "OJQGU46KAPROEJLCK674RHSAY5"
}
}
}
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@
{
"@timestamp": "2021-08-11T14:28:03.000Z",
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"action": "success",
Expand Down Expand Up @@ -79,7 +79,7 @@
{
"@timestamp": "2021-08-11T15:04:22.000Z",
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"action": "credentials_failed",
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -17,7 +17,7 @@ processors:
#######################
- set:
field: ecs.version
value: '8.10.0'
value: '8.11.0'
# Sets event.created from the @timestamp field generated by filebeat before being overwritten further down
- set:
field: event.created
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@
"type": "logs"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"elastic_agent": {
"id": "f25d13cd-18cc-4e73-822c-c4f849322623",
Expand Down
8 changes: 5 additions & 3 deletions packages/1password/docs/README.md
Original file line number Diff line number Diff line change
Expand Up @@ -91,7 +91,7 @@ An example event for `signin_attempts` looks as following:
"type": "logs"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"elastic_agent": {
"id": "f25d13cd-18cc-4e73-822c-c4f849322623",
Expand Down Expand Up @@ -232,7 +232,7 @@ An example event for `item_usages` looks as following:
"type": "logs"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"elastic_agent": {
"id": "f25d13cd-18cc-4e73-822c-c4f849322623",
Expand Down Expand Up @@ -297,6 +297,7 @@ An example event for `item_usages` looks as following:
"id": "OJQGU46KAPROEJLCK674RHSAY5"
}
}

```


Expand Down Expand Up @@ -380,7 +381,7 @@ An example event for `audit_events` looks as following:
"type": "logs"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"elastic_agent": {
"id": "f25d13cd-18cc-4e73-822c-c4f849322623",
Expand Down Expand Up @@ -452,4 +453,5 @@ An example event for `audit_events` looks as following:
"id": "GLF6WUEKS5CSNDJ2OG6TCZD3M4"
}
}

```
2 changes: 1 addition & 1 deletion packages/1password/manifest.yml
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
format_version: "3.0.0"
name: 1password
title: "1Password"
version: "1.24.0"
version: "1.25.0"
description: Collect logs from 1Password with Elastic Agent.
type: integration
categories:
Expand Down
2 changes: 1 addition & 1 deletion packages/akamai/_dev/build/build.yml
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
dependencies:
ecs:
reference: "git@v8.10.0"
reference: "git@v8.11.0"
5 changes: 5 additions & 0 deletions packages/akamai/changelog.yml
Original file line number Diff line number Diff line change
@@ -1,4 +1,9 @@
# newer versions go on top
- version: 2.20.0
changes:
- description: ECS version updated to 8.11.0.
type: enhancement
link: https://github.com/elastic/integrations/pull/8433
- version: "2.19.0"
changes:
- description: Improve 'event.original' check to avoid errors if set.
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -107,7 +107,7 @@
"ip": "89.160.20.156"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"category": [
Expand Down Expand Up @@ -272,7 +272,7 @@
"ip": "89.160.20.156"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"category": [
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@ description: Pipeline for parsing Akamai logs
processors:
- set:
field: ecs.version
value: '8.10.0'
value: '8.11.0'
- rename:
field: message
target_field: event.original
Expand Down
4 changes: 2 additions & 2 deletions packages/akamai/data_stream/siem/sample_event.json
Original file line number Diff line number Diff line change
Expand Up @@ -107,7 +107,7 @@
"type": "logs"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"elastic_agent": {
"id": "cdda426a-7e47-48c4-b2f5-b9f1ad5bf08a",
Expand Down Expand Up @@ -192,4 +192,4 @@
"port": 80,
"query": "a=../../../etc/passwd"
}
}
}
3 changes: 2 additions & 1 deletion packages/akamai/docs/README.md
Original file line number Diff line number Diff line change
Expand Up @@ -257,7 +257,7 @@ An example event for `siem` looks as following:
"type": "logs"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"elastic_agent": {
"id": "cdda426a-7e47-48c4-b2f5-b9f1ad5bf08a",
Expand Down Expand Up @@ -343,4 +343,5 @@ An example event for `siem` looks as following:
"query": "a=../../../etc/passwd"
}
}

```
2 changes: 1 addition & 1 deletion packages/akamai/manifest.yml
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
name: akamai
title: Akamai
version: "2.19.0"
version: "2.20.0"
description: Collect logs from Akamai with Elastic Agent.
type: integration
format_version: "3.0.0"
Expand Down
2 changes: 1 addition & 1 deletion packages/amazon_security_lake/_dev/build/build.yml
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
dependencies:
ecs:
reference: git@v8.10.0
reference: "git@v8.11.0"
import_mappings: true
5 changes: 5 additions & 0 deletions packages/amazon_security_lake/changelog.yml
Original file line number Diff line number Diff line change
@@ -1,4 +1,9 @@
# newer versions go on top
- version: 0.8.0
changes:
- description: ECS version updated to 8.11.0.
type: enhancement
link: https://github.com/elastic/integrations/pull/8433
- version: "0.7.0"
changes:
- description: Improve 'event.original' check to avoid errors if set.
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@
"region": "us-east-1"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"action": "create",
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@
"region": "us-east-1"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"action": "read",
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@
"region": "us-east-1"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"action": "logon",
Expand All @@ -16,7 +16,7 @@
],
"id": "fed06f42-cb12-4764-8c69-121063dc79b9",
"kind": "event",
"original": "{\"activity_id\":1,\"activity_name\":\"Logon\",\"actor\":{\"idp\":{},\"session\":{},\"user\":{\"account\":{\"uid\": \"112233445566\"},\"name\":\"anaya\",\"type\":\"IAMUser\",\"uid\":\"AIDACKCEVSQ6C2EXAMPLE\"}},\"api\":{\"operation\":\"ConsoleLogin\",\"request\":{\"uid\":\"''\"},\"response\":{},\"service\":{\"name\":\"signin.amazonaws.com\"}},\"category_name\":\"Audit Activity\",\"category_uid\":3,\"class_name\":\"Authentication\",\"class_uid\":3002,\"cloud\":{\"provider\":\"AWS\",\"region\":\"us-east-1\"},\"dst_endpoint\":{\"svc_name\":\"https://console.aws.amazon.com/console/home?state=hashArgs%23\u0026isauthcode=true\"},\"http_request\":{\"user_agent\":\"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36\"},\"metadata\":{\"product\":{\"feature\":{\"name\":\"Management\"},\"name\":\"CloudTrail\",\"vendor_name\":\"AWS\",\"version\":\"1.08\"},\"profiles\":[\"cloud\"],\"uid\":\"fed06f42-cb12-4764-8c69-121063dc79b9\",\"version\":\"1.0.0-rc.2\"},\"severity\":\"Informational\",\"severity_id\":1,\"src_endpoint\":{\"ip\":\"1.128.0.0\"},\"status\":\"Success\",\"status_id\":1,\"time\":1668097474000,\"type_name\":\"Authentication: Logon\",\"type_uid\":300201,\"unmapped\":{\"additionalEventData.MFAIdentifier\":\"arn:aws:iam::111122223333:u2f/user/anaya/default-AAAAAAAABBBBBBBBCCCCCCCCDD\",\"additionalEventData.MobileVersion\":\"No\",\"eventType\":\"AwsConsoleSignIn\",\"recipientAccountId\":\"111122223333\"},\"user\":{\"uid\":\"AIDACKCEVSQ6C2EXAMPLE\"}}",
"original": "{\"activity_id\":1,\"activity_name\":\"Logon\",\"actor\":{\"idp\":{},\"session\":{},\"user\":{\"account\":{\"uid\": \"112233445566\"},\"name\":\"anaya\",\"type\":\"IAMUser\",\"uid\":\"AIDACKCEVSQ6C2EXAMPLE\"}},\"api\":{\"operation\":\"ConsoleLogin\",\"request\":{\"uid\":\"''\"},\"response\":{},\"service\":{\"name\":\"signin.amazonaws.com\"}},\"category_name\":\"Audit Activity\",\"category_uid\":3,\"class_name\":\"Authentication\",\"class_uid\":3002,\"cloud\":{\"provider\":\"AWS\",\"region\":\"us-east-1\"},\"dst_endpoint\":{\"svc_name\":\"https://console.aws.amazon.com/console/home?state=hashArgs%23&isauthcode=true\"},\"http_request\":{\"user_agent\":\"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36\"},\"metadata\":{\"product\":{\"feature\":{\"name\":\"Management\"},\"name\":\"CloudTrail\",\"vendor_name\":\"AWS\",\"version\":\"1.08\"},\"profiles\":[\"cloud\"],\"uid\":\"fed06f42-cb12-4764-8c69-121063dc79b9\",\"version\":\"1.0.0-rc.2\"},\"severity\":\"Informational\",\"severity_id\":1,\"src_endpoint\":{\"ip\":\"1.128.0.0\"},\"status\":\"Success\",\"status_id\":1,\"time\":1668097474000,\"type_name\":\"Authentication: Logon\",\"type_uid\":300201,\"unmapped\":{\"additionalEventData.MFAIdentifier\":\"arn:aws:iam::111122223333:u2f/user/anaya/default-AAAAAAAABBBBBBBBCCCCCCCCDD\",\"additionalEventData.MobileVersion\":\"No\",\"eventType\":\"AwsConsoleSignIn\",\"recipientAccountId\":\"111122223333\"},\"user\":{\"uid\":\"AIDACKCEVSQ6C2EXAMPLE\"}}",
"outcome": "success",
"provider": "AWS",
"severity": 1,
Expand All @@ -27,7 +27,7 @@
},
"network": {
"application": [
"https://console.aws.amazon.com/console/home?state=hashargs%23\u0026isauthcode=true"
"https://console.aws.amazon.com/console/home?state=hashargs%23&isauthcode=true"
]
},
"ocsf": {
Expand Down Expand Up @@ -61,7 +61,7 @@
"region": "us-east-1"
},
"dst_endpoint": {
"svc_name": "https://console.aws.amazon.com/console/home?state=hashArgs%23\u0026isauthcode=true"
"svc_name": "https://console.aws.amazon.com/console/home?state=hashArgs%23&isauthcode=true"
},
"http_request": {
"user_agent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -34,7 +34,7 @@
"response_code": "NoError"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"action": "response",
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,7 @@
"port": 39938
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"action": "refuse",
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@
"region": "us-east-1"
},
"ecs": {
"version": "8.10.0"
"version": "8.11.0"
},
"event": {
"action": "update",
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ processors:
- set:
field: ecs.version
tag: set_ecs_version
value: 8.10.0
value: 8.11.0
- rename:
field: message
target_field: event.original
Expand Down
2 changes: 1 addition & 1 deletion packages/amazon_security_lake/manifest.yml
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
format_version: "3.0.0"
name: amazon_security_lake
title: Amazon Security Lake
version: "0.7.0"
version: "0.8.0"
description: Collect logs from Amazon Security Lake with Elastic Agent.
type: integration
categories: ["aws", "security"]
Expand Down
2 changes: 1 addition & 1 deletion packages/arista_ngfw/_dev/build/build.yml
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
dependencies:
ecs:
reference: "git@v8.10.0"
reference: "git@v8.11.0"
5 changes: 5 additions & 0 deletions packages/arista_ngfw/changelog.yml
Original file line number Diff line number Diff line change
@@ -1,4 +1,9 @@
# newer versions go on top
- version: 0.9.0
changes:
- description: ECS version updated to 8.11.0.
type: enhancement
link: https://github.com/elastic/integrations/pull/8433
- version: "0.8.0"
changes:
- description: Improve 'event.original' check to avoid errors if set.
Expand Down
Loading