-
Notifications
You must be signed in to change notification settings - Fork 15.5k
FAQ
See https://www.hardening-consulting.com/en/posts/20231004-smartcard-logon.html for a guide.
- there are entries like
[07:00:01:911] [1076502:00106d17] [ERROR][com.winpr.sspi.Kerberos] - [kerberos_AcquireCredentialsHandleA]: krb5glue_get_init_creds (Cannot find KDC for realm "YY" [-1765328230])?
-> check your /etc/krb5.conf.
FreeRDP now supports kerberos authentication and from bug reports we know that there are a lot of systems with broken KDC entries that are not reachable around.
- Remove these entries and the kerberos connect will fail fast and you will no longer see such delays.
- if you do not use kerberos anywhere else you can also just remove the file (an empty configuration is fine for
FreeRDP) (best rename the file so you can switch back if you should need it again)
-> There was a report that DNS with HighAvailability broker setups is not kerberos friendly, see https://github.com/FreeRDP/FreeRDP/issues/6508
-> If nothing else helps you can try /auth-pkg-list:!kerberos,!u2u (or '/auth-pkg-list:!kerberos,!u2u' if you need to escape !)
In any case:
- If you configured this yourself or your admin, check your kerberos configuration!
- If you use defaults provided by your distribution file bug reports, this is not acceptable behavior for a kerberos (default) configuration.
Windows 7 uses outdated sha1 hash for certificates. This is disabled by modern linux systems, so you can not connect with a failure of ERRCONNECT_TLS_CONNECT_FAILED
- Try adding
/tls-seclevel:1( or/tls-seclevel:0depending on distribution) to enableOpenSSLlegacy and a security level low enough for the connection to work
NOTE: With FreeRDP 3.x the command changed to /tls:seclevel:0
If you have issues and the above fix does not help try to check if your openssl can connect to the target with
openssl s_client -connect server.name:3389
if that command fails to establish a connection it might be due to:
- No network connection between the host and target
- No
RDPserver running on the target (or blocked by firewall rules) - No common ciphers supported (for example, the server uses outdated
TLS 1.0while you are on latest & greatestSSLwhich do no longer allowTLS 1.0)
It is necessary to put the scrolling speed to 5 or higher in the KDE mouse settings. Otherwise there is a weird behaviour, that scrolling is not recognized by MS-Windows.
Originally posted by @0140454 in https://github.com/FreeRDP/FreeRDP/issues/6766#issuecomment-769016036
Use /u:.\\AzureAD\\user@org.com or /u:'.\AzureAD\user@org.com' (captioned by the '')
See https://github.com/FreeRDP/FreeRDP/issues/5972
First you need to get the rdpw file from the webportal.
Log into https://client.wvd.microsoft.com/arm/webclient/v2/index.html
[update] https://github.com/FreeRDP/FreeRDP/issues/13094#issuecomment-5058825883
Set the resource launch method to "Download the rdp file"

Then you can launch the session by calling
freerdp <path to rdpw.rdpw> /gateway:type:arm /u:<username>
or
freerdp <path to rdpw.rdpw> /gateway:type:arm /sec:aad
The username is usually the same format as the Office 365 Credentials above. Sometimes only /sec:aad works
The FreeRDP team provides nightly builds for some distributions have a look to Pre-Builds.
For ubuntu it is also possible to use remmina which is shipping their own build of freerdp
For other distributions are currently no daily packages available so you will need to build from source - see compilation.
Further reading:
- http://comments.gmane.org/gmane.network.freerdp.devel/1469
- https://github.com/FreeRDP/FreeRDP/issues/352
Use the --data latency:X -- argument to specify the audio latency. X is in milliseconds.
Example command line:
xfreerdp -u user --no-nla -f --plugin rdpsnd --data latency:50 -- 192.168.x.x
Windows does not allow terminal output from an application. Try wfreerdp.exe >log.txt 2>&1 to redirect the output to a file.