S/MIME

S/MIME (Secure/Multipurpose Internet Mail Extensions) secure email

S/MIME RFCs (76)

Display RFCs as
  • RFC 9788: Header Protection for Cryptographically Protected Email

    Proposed Standard
  • RFC 9216: S/MIME Example Keys and Certificates

    Informational
  • RFC 9219: S/MIME Signature Verification Extension to the JSON Meta Application Protocol (JMAP)

    Proposed Standard
  • RFC 8823: Extensions to Automatic Certificate Management Environment for End-User S/MIME Certificates

    Informational
  • RFC 8550: Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Certificate Handling

    Proposed Standard
  • RFC 8551: Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Message Specification

    Proposed Standard
  • RFC 8591: SIP-Based Messaging with S/MIME

    Proposed Standard
  • RFC 8162: Using Secure DNS to Associate Certificates with Domain Names for S/MIME

    Experimental
  • RFC 7912: Message Authorizing Email Header Field and Its Use for the Draft and Release Procedure

    Informational
  • RFC 7508: Securing Header Fields with S/MIME

    Experimental
  • RFC 7281: Authentication-Results Registration for S/MIME Signature Verification

    Informational
  • RFC 7165: Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)

    Informational
  • RFC 7114: Creation of a Registry for smime-type Parameter Values

    Proposed Standard
  • RFC 7107: Object Identifier Registry for the S/MIME Mail Security Working Group

    Informational
  • RFC 6664: S/MIME Capabilities for Public Key Definitions

    Informational
  • RFC 6318: Suite B in Secure/Multipurpose Internet Mail Extensions (S/MIME)

    Historic
  • RFC 6210: Experiment: Hash Functions with Parameters in the Cryptographic Message Syntax (CMS) and S/MIME

    Experimental
  • RFC 6211: Cryptographic Message Syntax (CMS) Algorithm Identifier Protection Attribute

    Proposed Standard
  • RFC 6025: ASN.1 Translation

    Informational
  • RFC 5990: Use of the RSA-KEM Key Transport Algorithm in the Cryptographic Message Syntax (CMS)

    Proposed Standard

      Obsoleted by RFC 9690

  • RFC 5911: New ASN.1 Modules for Cryptographic Message Syntax (CMS) and S/MIME

    Informational
  • RFC 5912: New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)

    Informational
  • RFC 5750: Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Certificate Handling

    Proposed Standard

      Obsoleted by RFC 8550

  • RFC 5751: Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Message Specification

    Proposed Standard

      Obsoleted by RFC 8551

  • RFC 5752: Multiple Signatures in Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 5753: Use of Elliptic Curve Cryptography (ECC) Algorithms in Cryptographic Message Syntax (CMS)

    Informational
  • RFC 5754: Using SHA2 Algorithms with Cryptographic Message Syntax

    Proposed Standard
  • RFC 5652: STD 70: Cryptographic Message Syntax (CMS)

    Internet Standard
  • RFC 5408: Identity-Based Encryption Architecture and Supporting Data Structures

    Informational
  • RFC 5409: Using the Boneh-Franklin and Boneh-Boyen Identity-Based Encryption Algorithms with the Cryptographic Message Syntax (CMS)

    Informational
  • RFC 5275: CMS Symmetric Key Management and Distribution

    Proposed Standard
  • RFC 5126: CMS Advanced Electronic Signatures (CAdES)

    Informational
  • RFC 5083: Cryptographic Message Syntax (CMS) Authenticated-Enveloped-Data Content Type

    Proposed Standard
  • RFC 5084: Using AES-CCM and AES-GCM Authenticated Encryption in the Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 5008: Suite B in Secure/Multipurpose Internet Mail Extensions (S/MIME)

    Historic

      Obsoleted by RFC 6318

  • RFC 5035: Enhanced Security Services (ESS) Update: Adding CertID Algorithm Agility

    Proposed Standard
  • RFC 4853: Cryptographic Message Syntax (CMS) Multiple Signer Clarification

    Proposed Standard
  • RFC 4490: Using the GOST 28147-89, GOST R 34.11-94, GOST R 34.10-94, and GOST R 34.10-2001 Algorithms with Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 4262: X.509 Certificate Extension for Secure/Multipurpose Internet Mail Extensions (S/MIME) Capabilities

    Proposed Standard
  • RFC 4134: Examples of S/MIME Messages

    Informational
  • RFC 4056: Use of the RSASSA-PSS Signature Algorithm in Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 4010: Use of the SEED Encryption Algorithm in Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 3854: Securing X.400 Content with Secure/Multipurpose Internet Mail Extensions (S/MIME)

    Proposed Standard
  • RFC 3855: Transporting Secure/Multipurpose Internet Mail Extensions (S/MIME) Objects in X.400

    Proposed Standard
  • RFC 3850: Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.1 Certificate Handling

    Proposed Standard

      Obsoleted by RFC 5750

  • RFC 3851: Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.1 Message Specification

    Proposed Standard

      Obsoleted by RFC 5751

  • RFC 3852: Cryptographic Message Syntax (CMS)

    Proposed Standard

      Obsoleted by RFC 5652

  • RFC 3853: S/MIME Advanced Encryption Standard (AES) Requirement for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3657: Use of the Camellia Encryption Algorithm in Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 3560: Use of the RSAES-OAEP Key Transport Algorithm in Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 3565: Use of the Advanced Encryption Standard (AES) Encryption Algorithm in Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 3537: Wrapping a Hashed Message Authentication Code (HMAC) key with a Triple-Data Encryption Standard (DES) Key or an Advanced Encryption Standard (AES) Key

    Proposed Standard
  • RFC 3394: Advanced Encryption Standard (AES) Key Wrap Algorithm

    Informational
  • RFC 3369: Cryptographic Message Syntax (CMS)

    Proposed Standard

      Obsoleted by RFC 3852

  • RFC 3370: Cryptographic Message Syntax (CMS) Algorithms

    Proposed Standard
  • RFC 3274: Compressed Data Content Type for Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 3114: Implementing Company Classification Policy with the S/MIME Security Label

    Informational
  • RFC 3278: Use of Elliptic Curve Cryptography (ECC) Algorithms in Cryptographic Message Syntax (CMS)

    Informational

      Obsoleted by RFC 5753

  • RFC 3218: Preventing the Million Message Attack on Cryptographic Message Syntax

    Informational
  • RFC 3211: Password-based Encryption for CMS

    Proposed Standard

      Obsoleted by RFC 3369, RFC 3370

  • RFC 3217: Triple-DES and RC2 Key Wrapping

    Informational
  • RFC 3183: Domain Security Services using S/MIME

    Experimental
  • RFC 3185: Reuse of CMS Content Encryption Keys

    Proposed Standard
  • RFC 3125: Electronic Signature Policies

    Experimental
  • RFC 3126: Electronic Signature Formats for long term electronic signatures

    Informational

      Obsoleted by RFC 5126

  • RFC 3058: Use of the IDEA Encryption Algorithm in CMS

    Informational
  • RFC 2984: Use of the CAST-128 Encryption Algorithm in CMS

    Proposed Standard
  • RFC 2876: Use of the KEA and SKIPJACK Algorithms in CMS

    Informational
  • RFC 2785: Methods for Avoiding the "Small-Subgroup" Attacks on the Diffie-Hellman Key Agreement Method for S/MIME

    Informational
  • RFC 2630: Cryptographic Message Syntax

    Proposed Standard

      Obsoleted by RFC 3369, RFC 3370

  • RFC 2631: Diffie-Hellman Key Agreement Method

    Proposed Standard
  • RFC 2632: S/MIME Version 3 Certificate Handling

    Proposed Standard

      Obsoleted by RFC 3850

  • RFC 2633: S/MIME Version 3 Message Specification

    Proposed Standard

      Obsoleted by RFC 3851

  • RFC 2634: Enhanced Security Services for S/MIME

    Proposed Standard
  • RFC 2311: S/MIME Version 2 Message Specification

    Historic
  • RFC 2312: S/MIME Version 2 Certificate Handling

    Historic

Subscribe to S/MIME

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.