PRECIS

PRECIS (Preparation, Enforcement, and Comparison of Internationalized Strings) internationalized string handling

PRECIS RFCs (9)

Display RFCs as
  • RFC 8264: PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application Protocols

    Proposed Standard
  • RFC 8265: Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and Passwords

    Proposed Standard
  • RFC 8266: Preparation, Enforcement, and Comparison of Internationalized Strings Representing Nicknames

    Proposed Standard
  • RFC 7790: Mapping Characters for Classes of the Preparation, Enforcement, and Comparison of Internationalized Strings (PRECIS)

    Informational
  • RFC 7700: Preparation, Enforcement, and Comparison of Internationalized Strings Representing Nicknames

    Proposed Standard

    Obsoleted by RFC 8266

  • RFC 7622: Extensible Messaging and Presence Protocol (XMPP): Address Format

    Proposed Standard
  • RFC 7613: Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and Passwords

    Proposed Standard

    Obsoleted by RFC 8265

  • RFC 7564: PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application Protocols

    Proposed Standard

    Obsoleted by RFC 8264

  • RFC 6885: Stringprep Revision and Problem Statement for the Preparation and Comparison of Internationalized Strings (PRECIS)

    Informational

Subscribe to PRECIS

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.