NETCONF

The NETCONF (Network Configuration Protocol) configuration protocol

NETCONF subjects:

NETCONF RFCs (64)

Display RFCs as
  • RFC 10035: YANG Library: Addition of the augmented-by List

    Proposed Standard
  • RFC 9918: Updates to Using the NETCONF Protocol over Transport Layer Security (TLS) with Mutual X.509 Authentication

    Proposed Standard
  • RFC 9984: YANG Groupings for UDP Clients and UDP Servers

    Proposed Standard
  • RFC 9968: Report from the IAB Workshop on the Next Era of Network Management Operations (NEMOPS)

    Informational
  • RFC 9907: BCP 216: Guidelines for Authors and Reviewers of Documents Containing YANG Data Models

    Best Current Practice
  • RFC 9900: Updates to NETCONF Transport Port Numbers

    Proposed Standard
  • RFC 9890: An Update to YANG Module Names Registration

    Proposed Standard
  • RFC 9640: YANG Data Types and Groupings for Cryptography

    Proposed Standard
  • RFC 9641: A YANG Data Model for a Truststore

    Proposed Standard
  • RFC 9642: A YANG Data Model for a Keystore

    Proposed Standard
  • RFC 9643: YANG Groupings for TCP Clients and TCP Servers

    Proposed Standard
  • RFC 9644: YANG Groupings for SSH Clients and SSH Servers

    Proposed Standard
  • RFC 9645: YANG Groupings for TLS Clients and TLS Servers

    Proposed Standard
  • RFC 9646: Conveying a Certificate Signing Request (CSR) in a Secure Zero-Touch Provisioning (SZTP) Bootstrapping Request

    Proposed Standard
  • RFC 9403: A YANG Data Model for RIB Extensions

    Proposed Standard
  • RFC 9243: A YANG Data Model for DHCPv6 Configuration

    Proposed Standard
  • RFC 9196: YANG Modules Describing Capabilities for Systems and Datastore Update Notifications

    Proposed Standard
  • RFC 9182: A YANG Network Data Model for Layer 3 VPNs

    Proposed Standard
  • RFC 8676: YANG Modules for IPv4-in-IPv6 Address plus Port (A+P) Softwires

    Proposed Standard
  • RFC 8639: Subscription to YANG Notifications

    Proposed Standard
  • RFC 8640: Dynamic Subscription to YANG Events and Datastores over NETCONF

    Proposed Standard
  • RFC 8641: Subscription to YANG Notifications for Datastore Updates

    Proposed Standard
  • RFC 8572: Secure Zero Touch Provisioning (SZTP)

    Proposed Standard
  • RFC 8525: YANG Library

    Proposed Standard
  • RFC 8526: NETCONF Extensions to Support the Network Management Datastore Architecture

    Proposed Standard
  • RFC 8515: URN Namespace for ETSI Documents

    Informational
  • RFC 8512: A YANG Module for Network Address Translation (NAT) and Network Prefix Translation (NPT)

    Proposed Standard
  • RFC 8407: Guidelines for Authors and Reviewers of Documents Containing YANG Data Models

    Best Current Practice

      Obsoleted by RFC 9907

  • RFC 8404: Effects of Pervasive Encryption on Operators

    Informational
  • RFC 8349: A YANG Data Model for Routing Management (NMDA Version)

    Proposed Standard
  • RFC 8341: STD 91: Network Configuration Access Control Model

    Internet Standard
  • RFC 8342: Network Management Datastore Architecture (NMDA)

    Proposed Standard
  • RFC 8309: Service Models Explained

    Informational
  • RFC 8072: YANG Patch Media Type

    Proposed Standard
  • RFC 8022: A YANG Data Model for Routing Management

    Proposed Standard

      Obsoleted by RFC 8349

  • RFC 7950: The YANG 1.1 Data Modeling Language

    Proposed Standard
  • RFC 7895: YANG Module Library

    Proposed Standard

      Obsoleted by RFC 8525

  • RFC 7803: BCP 203: Changing the Registration Policy for the NETCONF Capability URNs Registry

    Best Current Practice
  • RFC 7758: Time Capability in NETCONF

    Experimental
  • RFC 7589: Using the NETCONF Protocol over Transport Layer Security (TLS) with Mutual X.509 Authentication

    Proposed Standard
  • RFC 7317: A YANG Data Model for System Management

    Proposed Standard
  • RFC 7223: A YANG Data Model for Interface Management

    Proposed Standard

      Obsoleted by RFC 8343

  • RFC 7224: IANA Interface Type YANG Module

    Proposed Standard
  • RFC 6991: Common YANG Data Types

    Proposed Standard

      Obsoleted by RFC 9911

  • RFC 6536: Network Configuration Protocol (NETCONF) Access Control Model

    Proposed Standard

      Obsoleted by RFC 8341

  • RFC 6470: Network Configuration Protocol (NETCONF) Base Notifications

    Proposed Standard
  • RFC 6241: Network Configuration Protocol (NETCONF)

    Proposed Standard
  • RFC 6242: Using the NETCONF Protocol over Secure Shell (SSH)

    Proposed Standard
  • RFC 6243: With-defaults Capability for NETCONF

    Proposed Standard
  • RFC 6244: An Architecture for Network Management Using NETCONF and YANG

    Informational
  • RFC 6110: Mapping YANG to Document Schema Definition Languages and Validating NETCONF Content

    Proposed Standard
  • RFC 6087: Guidelines for Authors and Reviewers of YANG Data Model Documents

    Informational

      Obsoleted by RFC 8407

  • RFC 6020: YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)

    Proposed Standard
  • RFC 6021: Common YANG Data Types

    Proposed Standard

      Obsoleted by RFC 6991

  • RFC 6022: YANG Module for NETCONF Monitoring

    Proposed Standard
  • RFC 5717: Partial Lock Remote Procedure Call (RPC) for NETCONF

    Proposed Standard
  • RFC 5607: Remote Authentication Dial-In User Service (RADIUS) Authorization for Network Access Server (NAS) Management

    Proposed Standard
  • RFC 5539: NETCONF over Transport Layer Security (TLS)

    Proposed Standard

      Obsoleted by RFC 7589

  • RFC 5381: Experience of Implementing NETCONF over SOAP

    Informational
  • RFC 5277: NETCONF Event Notifications

    Proposed Standard
  • RFC 4741: NETCONF Configuration Protocol

    Proposed Standard

      Obsoleted by RFC 6241

  • RFC 4742: Using the NETCONF Configuration Protocol over Secure SHell (SSH)

    Proposed Standard

      Obsoleted by RFC 6242

  • RFC 4743: Using NETCONF over the Simple Object Access Protocol (SOAP)

    Historic
  • RFC 4744: Using the NETCONF Protocol over the Blocks Extensible Exchange Protocol (BEEP)

    Historic

Subscribe to NETCONF

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.