RFC 7854 inline-errata, "BGP Monitoring Protocol (BMP)", June 2016

Source of RFC: grow (ops)

Updated by: RFC8671, RFC9069, RFC9515, RFC9736

Errata-ID: 7703

Status:
Verified
Type:
Technical
Reported By:
Dhananjay S. Patki
Date Reported:
2023-11-16
Verified by:
Warren Kumari (Ops AD)
Date Verified:
2023-12-11

Section 4.2 says:

      *  The L flag, if set to 1, indicates that the message reflects
         the post-policy Adj-RIB-In (i.e., its path attributes reflect
         the application of inbound policy).  It is set to 0 if the
         message reflects the pre-policy Adj-RIB-In.  Locally sourced
         routes also carry an L flag of 1.  See Section 5 for further
         detail.  This flag has no significance when used with route
         mirroring messages (Section 4.7).

It should say:

      *  The L flag, if set to 1, indicates that the message reflects
         the post-policy Adj-RIB-In (i.e., its path attributes reflect
         the application of inbound policy).  It is set to 0 if the
         message reflects the pre-policy Adj-RIB-In.  Locally sourced
         routes also carry an L flag of 1.  See Section 5 for further
         detail.  This flag has significance only when used with Route
         Monitoring messages.

Notes:

The L flag is used to indicate whether the route monitoring update reflects Adj-RIB-In pre-policy or post-policy (RFC 7854), or Adj-RIB-Out pre-policy or post-policy (RFC 8671). It does not apply to any message other than the Route Monitoring message.