Skip to content

deps: re-allow installer 0.7.0 - #10887

Merged
radoering merged 1 commit into
python-poetry:mainfrom
radoering:allow-older-installer
May 9, 2026
Merged

radoering merged 1 commit into
python-poetry:mainfrom
radoering:allow-older-installer

Conversation

@radoering

Copy link
Copy Markdown
Member

Pull Request Check List

Resolves: #10882

In #10869, we bumped the minimum required installer version because it fixes #10028.

However, there is another issue in the new installer version. See #10882 for details. Although the issue may not be relevant for Poetry itself, it is an issue for system package managers.

Re-allowing the older installer version should not hurt because it still works with Poetry (except for the specific use case described in #10028) and most users will get the latest version anyway.

@sourcery-ai sourcery-ai Bot left a comment

Copy link
Copy Markdown

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Hey - I've reviewed your changes and they look great!


Sourcery is free for open source - if you like our reviews please consider sharing them ✨
Help me be more useful! Please click 👍 or 👎 on each comment and I'll use the feedback to improve your reviews.

@dosubot

dosubot Bot commented May 8, 2026 •

Copy link
Copy Markdown

Documentation Updates

1 document(s) were updated by changes in this PR:

CHANGELOG
View Changes
@@ -12,7 +12,7 @@
 
 - Raise an error instead of silently ignoring a package name that is not a dependency when it is passed to `poetry update` ([#10721](https://github.com/python-poetry/poetry/pull/10721)).
 - Automatically add a trailing slash to legacy repository URLs (used for publishing) if missing ([#10785](https://github.com/python-poetry/poetry/pull/10785)).
-- Require `installer>=1.0.0` ([#10869](https://github.com/python-poetry/poetry/pull/10869)).
+- Require `installer>=0.7.0`. Although the minimum required installer version was bumped to `1.0.0` to fix [#10028](https://github.com/python-poetry/poetry/issues/10028) ([#10869](https://github.com/python-poetry/poetry/pull/10869)), it was reverted to `0.7.0` due to issues with system package managers ([#10882](https://github.com/python-poetry/poetry/issues/10882), [#10887](https://github.com/python-poetry/poetry/pull/10887)).
 - Allow `findpython>=0.8` ([#10874](https://github.com/python-poetry/poetry/pull/10874)).
 
 ### Fixed

How did I do? Any feedback?  Join Discord

@radoering
radoering enabled auto-merge (squash) May 9, 2026 07:31
@radoering
radoering disabled auto-merge May 9, 2026 07:31
@radoering
radoering merged commit c273de5 into python-poetry:main May 9, 2026
54 checks passed
mwalbeck pushed a commit to mwalbeck/docker-python-poetry that referenced this pull request May 24, 2026
This PR contains the following updates:

| Package | Update | Change |
|---|---|---|
| [poetry](https://github.com/python-poetry/poetry) ([changelog](https://python-poetry.org/history/)) | patch | `2.4.0` → `2.4.1` |

---

### Release Notes

<details>
<summary>python-poetry/poetry (poetry)</summary>

### [`v2.4.1`](https://github.com/python-poetry/poetry/blob/HEAD/CHANGELOG.md#241---2026-05-09)

[Compare Source](python-poetry/poetry@2.4.0...2.4.1)

##### Changed

- Re-allow `installer==0.7.0` ([#&#8203;10887](python-poetry/poetry#10887)).

##### Fixed

- Fix an issue where `poetry update <package>` failed when `<package>` was a transitive dependency ([#&#8203;10885](python-poetry/poetry#10885)).

</details>

---

### Configuration

📅 **Schedule**: (UTC)

- Branch creation
  - At any time (no schedule defined)
- Automerge
  - At any time (no schedule defined)

🚦 **Automerge**: Disabled by config. Please merge this manually once you are satisfied.

♻ **Rebasing**: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

🔕 **Ignore**: Close this PR and you won't be reminded about this update again.

---

 - [ ] <!-- rebase-check -->If you want to rebase/retry this PR, check this box

---

This PR has been generated by [Mend Renovate](https://github.com/renovatebot/renovate).
<!--renovate-debug:eyJjcmVhdGVkSW5WZXIiOiI0My4xNzAuMTkiLCJ1cGRhdGVkSW5WZXIiOiI0My4xNzAuMTkiLCJ0YXJnZXRCcmFuY2giOiJtYWluIiwibGFiZWxzIjpbXX0=-->

Reviewed-on: https://git.walbeck.it/mwalbeck/docker-python-poetry/pulls/1744
@younesaassila

Copy link
Copy Markdown

Now that pypa/installer#325 (that caused #10882) is fixed in installer v1.0.1, may you consider bumping the minimum required installer version to 1.0.1?
I encountered #10028 because of my multi-drive setup and the only fix right now seems to downgrade to specifically Poetry 2.4.0.

@radoering

Copy link
Copy Markdown
Member Author

I encountered #10028 because of my multi-drive setup and the only fix right now seems to downgrade to specifically Poetry 2.4.0.

Can you elaborate? Poetry 2.4.1 allows installer 1.0.1 and most of the ways to install Poetry should pick the latest installer by default. And even if they do not there is probably a way to force installer 1.0.1. In other words, I cannot imagine that a downgrade should be the only possible fix.

@younesaassila

Copy link
Copy Markdown

I encountered #10028 because of my multi-drive setup and the only fix right now seems to downgrade to specifically Poetry 2.4.0.

Can you elaborate? Poetry 2.4.1 allows installer 1.0.1 and most of the ways to install Poetry should pick the latest installer by default. And even if they do not there is probably a way to force installer 1.0.1. In other words, I cannot imagine that a downgrade should be the only possible fix.

Ok you're right, turns out pipx doesn't upgrade dependencies if it doesn't need to? So it reused installer 0.7.0. I had to fully uninstall Poetry then reinstall it and now it uses 1.0.1. Phew

@github-actions

Copy link
Copy Markdown

This pull request has been automatically locked since there has not been any recent activity after it was closed. Please open a new issue for related bugs.

@github-actions github-actions Bot locked as resolved and limited conversation to collaborators Jun 26, 2026
@radoering
radoering deleted the allow-older-installer branch August 22, 2026 04:57
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

poetry 2.4.0 requires installer >= 1.0.0 which has serious bugs requires-plugins breaks poetry installation on Windows

2 participants