Expected behaviour
Form names that are too long should throw a warning when they are manually created and subsequently truncated.
Form names that are too long should throw a warning or error in theme import.
Actual behaviour
Form names that are too long are silently truncated to their max length.
Form names that are too long are silently ignored / missed in theme import.
Steps to reproduce
Create a misc form called lorem_ipsum_dolor_sit_amet_consectetur_adipiscing_elit_gravidas (63 characters).
Rename the form to lorem_ipsum_dolor_sit_amet_consectetur_adipiscing_elit_gravidas_splat (69 characters).
Note the green confirmation.
Note the form name is still namedlorem_ipsum_dolor_sit_amet_consectetur_adipiscing_elit_gravidas (63 characters).
In a similar vein, importing a misc form called lorem_ipsum_dolor_sit_amet_consectetur_adipiscing_elit_gravidas_splat (69 characters) will silently fail.
Additional information
Textpattern version: 4.9.1
Web server vendor and version: Apache 2.4
Database server vendor and version: MariaDB 10.11
PHP version: 8.5
Operating system: Debian
Expected behaviour
Form names that are too long should throw a warning when they are manually created and subsequently truncated.
Form names that are too long should throw a warning or error in theme import.
Actual behaviour
Form names that are too long are silently truncated to their max length.
Form names that are too long are silently ignored / missed in theme import.
Steps to reproduce
Create a misc form called
lorem_ipsum_dolor_sit_amet_consectetur_adipiscing_elit_gravidas(63 characters).Rename the form to
lorem_ipsum_dolor_sit_amet_consectetur_adipiscing_elit_gravidas_splat(69 characters).Note the green confirmation.
Note the form name is still named
lorem_ipsum_dolor_sit_amet_consectetur_adipiscing_elit_gravidas(63 characters).In a similar vein, importing a misc form called
lorem_ipsum_dolor_sit_amet_consectetur_adipiscing_elit_gravidas_splat(69 characters) will silently fail.Additional information
Textpattern version: 4.9.1
Web server vendor and version: Apache 2.4
Database server vendor and version: MariaDB 10.11
PHP version: 8.5
Operating system: Debian