Unable to authenticate to AWS when running koding locally using the provided docker-compose set up. I have verified that I can authenticate with the same access key and secret access key using the aws cli on the host.
Expected Behavior
After entering a valid access key and secret access key koding should be able to verify the credentials. If unsuccessful the reason should be displayed in both the UI and logs.
Current Behavior
After entering a valid access key and secret access key to koding running in docker on my laptop I get the error:
We couldn't verify this credential, please check the ones you used or add a new credential to be able to continue to the next step.

When I check the logs of the kodingdockercompose_koding_1 container using docker logs <container id> I see the following
2018-04-09T05:55:40.426Z ERROR [Dispatcher:0 ][PID:573][models/pubnub.go:217] Could not grant access: Secret key is required will retry... (3 time(s))
2018-04-09T05:55:40.554Z ERROR [Dispatcher:0 ][PID:573][models/pubnub.go:217] Could not grant access: Secret key is required will retry... (3 time(s))
2018-04-09T05:55:41.362Z ERROR [Dispatcher:0 ][PID:573][models/pubnub.go:217] Could not grant access: Secret key is required will retry... (4 time(s))
2018-04-09T05:55:41.753Z ERROR [Dispatcher:0 ][PID:573][models/pubnub.go:217] Could not grant access: Secret key is required will retry... (4 time(s))
2018-04-09T05:55:42.549Z ERROR [Dispatcher:0 ][PID:573][models/pubnub.go:217] Could not grant access: Secret key is required will retry... (5 time(s))
2018-04-09T05:55:43.206Z ERROR [Dispatcher:0 ][PID:573][models/pubnub.go:217] Could not grant access: Secret key is required will retry... (5 time(s))
There is no stack template assigned for blergy group
{ [NotFound: Template not set] message: 'Template not set', name: 'NotFound' }
2018-04-09T05:55:45.26Z ERROR [Dispatcher:0 ][PID:573][models/pubnub.go:217] Could not grant access: Secret key is required will retry... (6 time(s))
2018-04-09T05:55:46.656Z ERROR [Dispatcher:0 ][PID:573][models/pubnub.go:217] Could not grant access: Secret key is required will retry... (6 time(s))
2018-04-09T05:55:48.272Z ERROR [Dispatcher:0 ][PID:573][models/pubnub.go:217] Could not grant access: Secret key is required will retry... (7 time(s))
2018-04-09T05:55:49.683Z ERROR [Dispatcher:0 ][PID:573][models/pubnub.go:217] Could not grant access: Secret key is required will retry... (7 time(s))
2018-04-09T05:55:49.683Z ERROR [Dispatcher:0 ][PID:573][dispatcher/dispatcher.go:35] an error occurred deleting dispatcher event: Secret key is required
2018-04-09T05:55:55.406Z ERROR [Dispatcher:0 ][PID:573][models/pubnub.go:217] Could not grant access: Secret key is required will retry... (8 time(s))
2018-04-09T05:55:55.406Z ERROR [Dispatcher:0 ][PID:573][dispatcher/dispatcher.go:35] an error occurred deleting dispatcher event: Secret key is required
I have checked using the 'preview' button that it does in fact have a secret key.
Steps to Reproduce (for bugs)
- Start the koding containers using https://github.com/koding/docker-compose
- Create an account and team
- Navigate to credentials
- Add a new credential
- Enter valid aws credentials, a name (I used "dev services", "other region" and "blerg") and region (I used ap-southeast-2 and us-east-1)
- Select 'Use this & continue', and see the error saying it can't be verified.
Context
I am trying to connect koding to my aws account so I can spin up stacks.
Your Environment
Fedora 27, docker-compose version 1.17.1 build 6d101fb, commit 18dfac82 in koding-docker-compose, Firefox Quantum 58.0.2 (64-bit), Docker version 1.13.1 build caba767-unsupported, Chromium Version 65.0.3325.181 (Developer Build) Fedora Project (64-bit)
Unable to authenticate to AWS when running koding locally using the provided docker-compose set up. I have verified that I can authenticate with the same access key and secret access key using the aws cli on the host.
Expected Behavior
After entering a valid access key and secret access key koding should be able to verify the credentials. If unsuccessful the reason should be displayed in both the UI and logs.
Current Behavior
After entering a valid access key and secret access key to koding running in docker on my laptop I get the error:

We couldn't verify this credential, please check the ones you used or add a new credential to be able to continue to the next step.When I check the logs of the
kodingdockercompose_koding_1container usingdocker logs <container id>I see the followingI have checked using the 'preview' button that it does in fact have a secret key.
Steps to Reproduce (for bugs)
Context
I am trying to connect koding to my aws account so I can spin up stacks.
Your Environment
Fedora 27, docker-compose version 1.17.1 build 6d101fb, commit
18dfac82in koding-docker-compose, Firefox Quantum 58.0.2 (64-bit), Docker version 1.13.1 build caba767-unsupported, Chromium Version 65.0.3325.181 (Developer Build) Fedora Project (64-bit)