Skip to content

setup.sh email list gives ERROR listmailuser: This command is only compatible with 'ACCOUNT_PROVISIONER=FILE'聽#4812

Description

@fawzibr

馃摑 Preliminary Checks

  • I tried searching for an existing issue and followed the debugging docs advice, but still need assistance.
  • I will disclose any AI assistance I have used with the information I provide in my report, so that I do not waste the time of humans trying to help me.

馃憖 What Happened?

When trying to list emails using setup.sh outside of the docker container it does not work. I can create users with ./setup.sh email add , but ./setup.sh email list always fails with the error:

ERROR listmailuser: This command is only compatible with 'ACCOUNT_PROVISIONER=FILE'

In mailserver.env ACCOUNT_PROVISIONER is empty. The comments says defaults to FILE, changed to FILE, still fails.

This used to work on older versions. If I run from inside the container using:

docker exec -it <mailserver-container-name> setup email list

It works ok.

馃憻 Reproduction Steps

  • Created new folder for install /opt/mailserver
  • Created required folders in /opt/mailserver (docker-data/dms/config, etc.)
  • Downloaded compose.yaml to /opt/mailserver/compose.yaml
  • Downloaded mailserver.env to /opt/mailserver/mailserver.env
  • Downloaded setup.sh to /opt/mailserver/setup.sh
  • Edited compose.yaml and mailserver.env to set environment
  • Executed /opt/mailserver/setup.sh email add , it works
  • Executed /opt/mailserver/setup.sh email list - does not work

馃悑 DMS Version

v16.0.1

馃捇 Operating System and Architecture

Ubuntu 24.04.5 LTS X86-64

鈿欙笍 Container configuration files

services:
  mailserver:
    image: ghcr.io/docker-mailserver/docker-mailserver:latest
    container_name: mailserver
    hostname: <my_server>
    env_file: mailserver.env
    ports:
      - "25:25"
      - "143:143"
      - "465:465"
      - "587:587"
      - "993:993"
    volumes:
      - ./docker-data/dms/mail-data/:/var/mail/
      - ./docker-data/dms/mail-state/:/var/mail-state/
      - ./docker-data/dms/mail-logs/:/var/log/mail/
      - ./docker-data/dms/config/:/tmp/docker-mailserver/
      - /etc/localtime:/etc/localtime:ro
    restart: always
    stop_grace_period: 1m
    cap_add:
      - NET_ADMIN

馃摐 Relevant log output


Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Labels

kind/bug/reportA report about a bugmeta/needs triageThis issue / PR needs checks and verification from maintainers

Type

No type

Projects

No projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions