馃摑 Preliminary Checks
馃憖 What Happened?
When trying to list emails using setup.sh outside of the docker container it does not work. I can create users with ./setup.sh email add , but ./setup.sh email list always fails with the error:
ERROR listmailuser: This command is only compatible with 'ACCOUNT_PROVISIONER=FILE'
In mailserver.env ACCOUNT_PROVISIONER is empty. The comments says defaults to FILE, changed to FILE, still fails.
This used to work on older versions. If I run from inside the container using:
docker exec -it <mailserver-container-name> setup email list
It works ok.
馃憻 Reproduction Steps
- Created new folder for install /opt/mailserver
- Created required folders in /opt/mailserver (docker-data/dms/config, etc.)
- Downloaded compose.yaml to /opt/mailserver/compose.yaml
- Downloaded mailserver.env to /opt/mailserver/mailserver.env
- Downloaded setup.sh to /opt/mailserver/setup.sh
- Edited compose.yaml and mailserver.env to set environment
- Executed /opt/mailserver/setup.sh email add , it works
- Executed /opt/mailserver/setup.sh email list - does not work
馃悑 DMS Version
v16.0.1
馃捇 Operating System and Architecture
Ubuntu 24.04.5 LTS X86-64
鈿欙笍 Container configuration files
services:
mailserver:
image: ghcr.io/docker-mailserver/docker-mailserver:latest
container_name: mailserver
hostname: <my_server>
env_file: mailserver.env
ports:
- "25:25"
- "143:143"
- "465:465"
- "587:587"
- "993:993"
volumes:
- ./docker-data/dms/mail-data/:/var/mail/
- ./docker-data/dms/mail-state/:/var/mail-state/
- ./docker-data/dms/mail-logs/:/var/log/mail/
- ./docker-data/dms/config/:/tmp/docker-mailserver/
- /etc/localtime:/etc/localtime:ro
restart: always
stop_grace_period: 1m
cap_add:
- NET_ADMIN
馃摐 Relevant log output
馃摑 Preliminary Checks
馃憖 What Happened?
When trying to list emails using setup.sh outside of the docker container it does not work. I can create users with ./setup.sh email add , but ./setup.sh email list always fails with the error:
ERROR listmailuser: This command is only compatible with 'ACCOUNT_PROVISIONER=FILE'In mailserver.env ACCOUNT_PROVISIONER is empty. The comments says defaults to FILE, changed to FILE, still fails.
This used to work on older versions. If I run from inside the container using:
docker exec -it <mailserver-container-name> setup email listIt works ok.
馃憻 Reproduction Steps
馃悑 DMS Version
v16.0.1
馃捇 Operating System and Architecture
Ubuntu 24.04.5 LTS X86-64
鈿欙笍 Container configuration files
馃摐 Relevant log output