quopri --- Encode and decode MIME quoted-printable data¶
Code source : Lib/quopri.py
Ce module effectue des encodages et décodages de transport quoted-printable, tel que définis dans la RFC 1521 : "MIME (Multipurpose Internet Mail Extensions) Part One Mechanisms for Specifying and Describing the Format of Internet Message Bodies". L'encodage quoted-printable est adapté aux données dans lesquelles peu de données ne sont pas affichables. L'encodage base64 disponible dans le module base64 est plus compact dans les cas où ces caractères sont nombreux, typiquement pour encoder des images.
- quopri.decode(input, output, header=False, *, strip_ws=False)¶
Decode the contents of the input file and write the resulting decoded binary data to the output file. input and output must be binary file objects. If the optional argument header is present and true, underscore will be decoded as space. This is used to decode "Q"-encoded headers as described in RFC 1522: "MIME (Multipurpose Internet Mail Extensions) Part Two: Message Header Extensions for Non-ASCII Text". If the optional argument strip_ws is true, trailing whitespace is stripped from each line, as required by RFC 2045.
Modifié dans la version 3.16.0a1 (unreleased): Added the strip_ws parameter.
- quopri.encode(input, output, quotetabs, header=False)¶
Encode le contenu du fichier input et écrit le résultat dans le fichier output. input et output doivent être des objets fichiers binaires. quotetabs (paramètre obligatoire) permet de choisir le style d'encodage des espaces et des tabulations, si vrai les espaces seront encodées, sinon elles seront laissées inchangées. Notez que les espaces et tabulations en fin de ligne sont toujours encodées, tel que spécifié par la RFC 1521. header est une option permettant d'encoder les espace en underscores, tel que spécifié par la RFC 1522.
- quopri.decodestring(s, header=False, *, strip_ws=False)¶
Fonctionne comme
decode(), sauf qu'elle accepte desbytescomme source, et renvoie lesbytesdécodés correspondants.Modifié dans la version 3.16.0a1 (unreleased): Added the strip_ws parameter.
- quopri.encodestring(s, quotetabs=False, header=False)¶
Fonctionne comme
encode(), sauf qu'elle accepte desbytescomme source et renvoie lesbytesencodés correspondants. Par défaut,Falseest donné au paramètre quotetabs de la fonctionencode().
Voir aussi
- Module
base64 Encode et décode des données MIME en base64